internal package Foswiki::Compatibility

See PublishedAPI for packages intended to be used by Plugin and Contrib authors, or browse all packages.
See also Developing plugins, Developer's Bible, Technical Overview

internal package Foswiki::Compatibility

Support for compatibility with old versions. Packaged separately because 99.999999% of the time this won't be needed.

StaticMethod upgradeCategoryTable( $session, $web, $topic, $meta, $text ) → $text

Upgrade old style category table

May throw Foswiki::OopsException

migrateToFileAttachmentMacro ( $session, $meta, $text ) -> $text

Migrate old HTML format

upgradeFrom1v0beta ( $session, $meta ) -> $text

Topic revision: r1 - 21 Nov 2014, ProjectContributor

  • User Reference
  • BeginnersStartHere
  • EditingShorthand
  • Macros
  • MacrosQuickReference
  • FormattedSearch
  • QuerySearch
  • DocumentGraphics
  • SkinBrowser
  • InstalledPlugins

  • Admin Maintenance
  • Reference Manual
  • AdminToolsCategory
  • InterWikis
  • ManagingWebs
  • SiteTools
  • DefaultPreferences
  • WebPreferences

This site is powered by FoswikiCopyright &© by the contributing authors. All material on this site is the property of the contributing authors.
Ideas, requests, problems regarding Asteroid observations? Send feedback